Error “This identity cannot be opened with this version of Outlook” in Outlook 2011

To solve this annoying error when reinstalling Outlook 2011, you receive the following error message: “This identity cannot be opened with this version of Outlook”   issue, please follow the steps listed below by Diane Ross MVP:

1) Launch the Microsoft Autoupdater (MAU).

2) To launch MAU, you can open any Office application and select Check for Updates under Help in the Menu bar. Once MAU is launched, select Keep in Dock

3) Quit all Microsoft applications (Easy way: log out. When you log in, hold down the Shift key. This will disable all startup items including the hidden ones. It¹s important all Microsoft applications are quit, but quitting all applications will result in fewer problems overall. Any open application could be corrupted by the process.

4) Select the MAU from the Dock. Download updater suggested and install. Restart between each update. (sometimes the temp folder where the update wants to write to is locked, restarting your machine clears the temp folder and rectifies this problem)

5) You can remove the MAU from Dock after you complete the update.

Running Repair Permissions can also be helpful. Use Disk Utility in
Applications/Utilities.